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CANoe概述

CAN 总线开发工具

测试

分析

仿真

记录
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CANoe在总线开发中的作用（ 1）
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CANoe在总线开发中的作用（ 2）
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CANoe在总线开发中的作用（ 3）

5

Phase 3

real
node

2

…

real
node

1

ω

Kl 15

Real total system

real
node

n
…

Physical bus

Analysis(in real-time)



© 2009. HiRain Technologies. All rights reserved.

Slide: 

硬件接口卡 &“ 狗”

 CANcardXL

 CANcaseXL

收发器

 CANcab (CANpiggy)
 251, 1041, 1054…

 LINcab (LINpiggy)
 7259
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CAN卡
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CANoe组成

功能强大、操作简单

 CANoe

数据库支持

 CANdb++ Editor

可编程

 CAPL 、 DLL

虚拟仪表

 Panel Editor & Panel Designer
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多总线

软件

硬件

控制面板

 Vector Hardware
❑ License->Overview
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使用设置（ 1）

硬件

 CAN 卡类型（编号）

收发器类型

 应用程序通道

应用程序

 License 信息
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使用设置（ 2）

CANoe
通道设置

 Configuration->Options
 Configuration Settings->Channel Usage
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灵活＝复杂
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HW channels Channel1    Channel2         Channel1  Channel2       PiggyBack1   PiggyBack2

CANcardXL #1 CANcaseXLCANcardXL #2

Hardware

CANalyzer1    CANalyzer2...                 CANoe1    CANoe2   CANoe1 for LIN...App channels

Application
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从复杂到简单

CANoe
波特率设置

 Configuration->Hardware Configuration
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——基本术语 报文（消息）与信号

13

报文： engine data (ID 100)

ID 100 B0 B1 B2 CRC

信号

发动机温度（第二字节， 0-6
位）
未用 ( 第二字节，第七位 )

发动机转速（第一，二字
节）

转换规则
发动机转速 ： rpm=1*Bit value          (0xFF  代表错
误 )
发动机温度： ºC =2* Bit value –50    (0x7F 代表错
误 )
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——基本术语 环境变量与系统变量

环境变量

节点的 I/O 信号

可用于面板或真实 I/O

系统变量

节点内部参数

或需要观测的某个数值

 例如：系统变量 1 = 报文 1. 信号 1 － 报文 2. 信号 2
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欢迎进入 CANoe的世界

CANoe

CANdb++ Editor

CAPL

Panel Editor & Panel Designer

15
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欢迎进入 CANoe的世界

CANoe
 8 大窗口

 Trace Window

 Bus Statistics Window

 Statistics Window

 Data Window

 Graphic Window

 Write Window

 Simulation Setup

 Measurement Setup

16
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CANoe窗口介绍（ 1）

Trace Window
报文 ID 和报文名称（数据库）

信号（数据库）

时间（相对值或绝对值）

通道

 DLC

 Dir （ Tx 或 Rx ）

更多内容见

 右键点击窗口空白处 ->Configuration->Columns

17
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CANoe窗口介绍（ 1）
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清空 Trace 窗
口

暂停 Trace 窗
口

差额（相对）时间显示

卷屏（绝对）时间显示

报文详细信息

窗口显示配置

Trace 窗口查
找
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CANoe窗口介绍（ 2）

Data Window
数据库

信号名称

信号值（ Value ）

信号单位

原始值（ Raw Value ）

 Bar 图
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Data Window
添加信号

 右键单击空白处

 Add Signals

 选择需要的信号

支持鼠标拖放

CANoe窗口介绍（ 2）

20
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CANoe窗口介绍（ 3）

Graphics Windows
支持数据库

显示信号曲线

不同的颜色和线形

 右键单击空白处

 选择 Configuration

放大、缩小、平移…
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CANoe窗口介绍（ 3）

Graphics Windows
添加信号

 右键单击空白处

 Add Signals

 选择需要的信号

支持鼠标拖放

与Trace窗口同步
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CANoe窗口介绍（ 4）

Statistics Window
显示报文出现频率

显示错误帧出现频率

统计报告

 右键单击空白处

 Configuration

 Active

 生成统计报告 (Write Window)

23

Message frequency

ID
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CANoe窗口介绍（ 5）

Bus Statistics Window
总线负载

数据帧

错误帧

 CAN 卡控制器状态

 ACTIVE

 WARNING

 PASSIVE

 OFF

24
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CANoe窗口介绍（ 6）

Write Window
总线负载

数据帧

错误帧

 CAN 卡控制器状态

 License 信息

统计报告

 CAPL 输出窗口

 Printf = Write

25
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CANoe窗口介绍（ 7）

Measurement Setup
 View->Measurement Setup

 每个模块对应一个窗口

 增加新模块（窗口）

 插入功能块

 数据记录

26
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CANoe窗口介绍（ 7）

新增模块（窗口）

主干线上右键

27
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CANoe窗口介绍（ 7）

插入功能块

支线上节点上右键
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CANoe窗口介绍（ 7）

数据记录

默认状态关闭

多种记录文件格式

多种记录触发配置

29
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CANoe窗口介绍（ 7）

记录文件

右键点击文件图标 ->Logging file configuration

30
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CANoe窗口介绍（ 7）

记录配置方式

双击 Logging 模块

 全部记录

 单次记录

 触发记录

记录数据回放
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CANoe窗口介绍（ 8）

Simulation Setup
 View->Simulation Setup

 主干线添加模块

32
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CANoe窗口介绍（ 8）

Simulation Setup
 View->Simulation Setup

 支线添加模块

33
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CANoe练习

1. 周期报文发送

2. 梯形信号发送

3. 正弦信号发送

34
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 练习 1

发生器模块发送周期报文

设置发送内容

35
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 练习 1

发生器模块发送周期报文

设置发送周期
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 练习 2

发生器模块发送阶梯信号
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 练习 3

交互式发生器模块发送正弦信号
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欢迎进入 CAPL的世界

CAPL (CAN Access Programming Language )
类 C 语言

仿真

 单个节点和整个网络

 外部环境

 测试

面向事件的编程语言

 总线事件

 键盘事件

 时间事件

39
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CAPL Browser

40

标题栏
菜单条
工具条

浏览树窗格

编译信息窗格

状态条

全局变量编辑窗格

CAPL 程序编辑窗
格
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CAPL事件
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事件类型事件类型 事件名事件名 程序执行条件程序执行条件 事件过程语法结构 事件过程语法结构 **

系统事件 PreStart CANoe初始化时执行 on preStart { … }

Start 测量开始时执行 on start { … }

StopMeasuremet 测量结束时执行 on stopMeasurement { … }

CAN控制器

事件

BusOff 硬件检测到 BusOff 时执行 on busOff { … }

ErrorActive 硬件检测到 ErrorActive 时执行 on errorActive { … }

ErrorPassive 硬件检测到 ErrorPassive 时执行 on errorPassive { … }

WarningLimit 硬件检测到 WarningLimit 时执行 on warningLimit { … }

CAN消息事件 自定义 接收到指定的消息时执行 on message Message { … }

时间事件 自定义 定时时间朝过时执行 on timer Timer { … }

键盘事件 自定义键值 指定的键被下时执行 on key Key { … }

错误帧事件 ErrorFrame 硬件每次检测到错误帧时执行 on errorFrame { … }

环境变量事件 自定义 指定的环境变量值改变时执行 on envVar EnvVar { … }
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CAPL基本语法

类 C 语言，语法与 C 语言基本相同

注释

 // 放置在需要注释的语句之前，注释单行

 /* 注释起始符，其后的内容被注释

 */ 注释结束符，结束由‘ /*’ 开始的注释

分号 程序结束标识

大括号 函数体

42

counter = counter+1;
if (counter==256)
 {
     counter=0;
     stop();
 }
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消息事件

 on message 123               // 对消息 123(dec) 反应

 on message 0x123           // 对消息 123(hex) 反应

 on message MotorData    // 对消息 MotorData( 符号名字 ) 反应

 on message CAN1.123    // 对 CAN 通道 1 收到消息 123 反应

 on message *                   // 对所有消息反应

 on message 100-200       // 对 100-200 间消息反应
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键盘事件

 on key ‘a’ //按‘ a’ 键反应

 on key ‘ ’                      //按空格键反应

 on key 0x20                //按空格键反应

 on key F1                   //按 F1 键反应

 on key Ctrl-F12           //按 Ctrl + F12 键反应

 on key PageUP           //按 PageUp 键反应

 on key Home             //按 Home 键反应

 on key *                   //按所有键反应

44
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时间事件

定时器声明

 msTimer myTimer;  //将 myTimer 申明 ms为单位的变量

 timer  myTimer;     //将 myTimer 申明 s为单位的变量

定时器函数

 setTimer(myTimer,20); //将定时值设定为 20ms ，并启
动

 cancelTimer(myTimer); //停止定时器 myTimer

定时器事件

 on timer myTimer // 对 myTimer 设定的时间到反
应
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环境变量事件

环境变量函数

 getValue() //获取环境变量的值

 putValue() // 设置环境变量的值

环境变量事件

 on envVar XXX

46
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数据类型
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数据定义

全局变量和局部变量

变量定义

int i;

message 0x123 HiRain;

message MotorData Vector;

48
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完整的 CAPL程序

三个部分

变量

各种事件

自定义函数

49

on start 
{
     … // 过程指令块 
} 

on message xxx
{
     … // 过程指令块 
} 

on key ‘1’
{
     … // 过程指令块 
} 

My_function_1(Para_1, Para_2, …)
{
     …  // 函数体
} 

…

My_function_n(Para_1, Para_2, …)
{
     … // 函数体
} 

variables
{
     … // 申明全局变量 
} 
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CAPL输出文本

Write Window
 write 函数

50

int h=100;
char ch=‘a’;
char s100[8]=“hundred”;
write(“Hundred as a  number:%d,%x”,h,h);
write(“Hundred as a  string:%s”,s100);
write(“The square root of two is %6.4g”,sqrt(2.0));
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消息处理常用语句

if (this.id==100) {…}

msg.can=2;

msg.dlc=8;

dword t ; t=this.time;

if(this.dir!=RX) {return;}

this.CarSpeed = 200;

51
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关键字 this

this代表触发事件的对象

52

on message 100 {
byte byte_0;
byte_0 = this.byte(0);
...

}

on envVar Switch {
int val;
val = getvalue(this);
...

}
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报文处理

on message 0x64
{
    if(this.byte(2)==0xFF)
         write(“Third byte of the message is invalid”);
}
on message MotorData
{
    if(this.temperature.phys>=150) 
         write(“Warning: critical temperature”);
}

53



© 2009. HiRain Technologies. All rights reserved.

Slide: 

键盘处理

on key ‘a’ {
     message MotorData mMoDa;
     mMoDa.temperature.phys=60;
     mMoDa.speed.phys=4300;
     output(mMoDa);
}
on key ‘b’ {
      message 100 m100= {dlc=1};
      m100.byte(0)=0x0B;
      output(m100);
}
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定时器处理
Variables
{

message 0x555 msg1 = {dlc=1}; 
msTimer timer1; 

}

on start
{

setTimer(timer1,100); 
}

on timer timer1
{

setTimer(timer1,100); 
msg1.byte(0)=msg1.byte(0)+1; 
output(msg1); 

}
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环境变量处理

on envVar evSwitch 
{

message MotorData msg;
msg.bsSwitch = getValue(this);
output(msg);

}

56
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CAPL练习

1. Hello World

2. 报文计数

3. 信号监控

57
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练习 1

当 CANoe启动时，向 Write Window 输出一句话
，例如“ Hello the world!”

58
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练习 2

利用发生器模块周期性发送某一报文，例如每隔
200ms 发送一条 EngineData 报文。每当按下 a 键
，在 Write Window 窗口输出一句话，例如“ 
XXX EngineData messages have sent.”
注： XXX为已经发送的 EngineData 报文数量。

59
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练习 3

不用发生器模块实现 Enginedata 报文的周期性发送。

每当按下 a 键时， EngineData里面 EngSpeed 信号值
为 2000；当按下 b 键盘时， EngineData里面
EngSpeed 信号值为 4000；

如果 EngineData里面 EngSpeed 信号为 4000 ，则发送
ABSData 报文，同时在 Write Window 输
出“Warning!”

当按下 c 键时，停止 EngineData 报文发送。

60
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欢迎进入 CANdb++ Editor的世界

DBC文件编辑工具
启动 CANoe

 File->Open CANdb Editor

点击

61
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创建一个新的 CAN数据库

 File->Create Database… 

 选择模板，鼠标双击或

     按 [OK]按钮

 指定数据库文件类型、

    文件名及保存目录

 按 [Save]按钮。

    一个新数据库创建完成

62
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创建对象（信号、报文、节点、环境变量和 ECU）

 在 Overview 窗口左边

  选择所需创建对象的类型

 右键点击对象类型，

  在快捷菜单中选择 New…

 使用配置对话框设置

    所创建对象的系统参数值

 点击 [确定 ]按钮，

     一个新对象便创建完毕
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复制已有对象

Copy-Paste
选择已有对象 Ctrl+c

选择对象类型 Ctrl+v

64



© 2009. HiRain Technologies. All rights reserved.

Slide: 

修改 /编辑已有对象

直接双击

65
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对象链接 (1/2)

信号与报文之间的连接

发送报文与节点之间的连接

 鼠标拖拽或 Copy-Insert

66
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对象链接 (2/2)

接收报文与节点之间的连接

通过信号间接定义

 双击节点，

  选择 Mapped Rx Sig.页签

 点击 Add… ，选择接收信号

点击 OK

 点击确定

67
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通信矩阵

View->Communication Matrix…
显示信号、消息、及网络节点的关系
以信号为行，网络节点为列
消息名显示于表中，对应了包含的信号与发送 /接收的
节点

68
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数值表 (1/2)

新建数值表

 View->Value Talbes

右键点击空白处，

 选择 New…
在对话框中输入数值，

点击确定
新的数值表创建完成
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数值表 (2/2)

分配数值表

数值表可以分配给信号或环境变量
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属性列表
Vector Tool Chain Attributes

 General
 Manufacturer

 Interaction Layer
 GenMsgCycleTime

 Transport Protocol and Diagnostics
 DiagRequest, DiaResponse

 Network Management
 NmBaseAddress, NmStationAdress

 Tool specific
 BusType

71
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新建属性

 View->Attribute Definitions

右键点击空白处，

 选择 New…
在对话框中输入相关参数，

点击确定
新的属性创建完成
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对象属性修改

双击对象

73



© 2009. HiRain Technologies. All rights reserved.

Slide: 

一致性检查

File-> Consistency Check
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数据导出

选择需要导出的对象
信号，报文，节点， ECU或网络

File->Export->Export List of Objects
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欢迎进入 Panel Editor&Panel Designer的世界

Panel Editor
传统的面板编辑器

 File->Open Panel Editor

Panel Designer
新的面板编辑器

 File->Open Panel Designer
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Panel Editor
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面板区

控件区
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面板设置

Options->Window setting
定义面板名称

面板尺寸

背景颜色

透明色

控件的缺省字体和颜色

Options->Change grid
网格大小

网格可视
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控件列表
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图标

名称
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文本与位图

文本
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位图



© 2009. HiRain Technologies. All rights reserved.

Slide: 

开关与多态位图

开关
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多态位图
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其它常见的控件

十六进制
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滑动条

仪表

输入 / 输出显示
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面板使用

保存面板

 File->Save

使用面板（ CANoe ）
 Configuration->Panel Configuration
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添加面板

显示面板
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Panel Designer
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控件窗口

控件属性

工作区

对象窗口



© 2009. HiRain Technologies. All rights reserved.

Slide: 

设置

Settings->Controls Properties
设置控件的字体、颜色和字号

Settings->Symbol Explorer
设置信号、环境变量和系统变量

对应的默认控件
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对象窗口

显示信号、环境变量和系统变量

直接拖拽变量到工作区生成控件
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工作区

创建面板

支持同时编辑多个面板
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控件窗口

显示控件

双击在工作区产生控件
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控件属性窗口

显示选中控件的相关设置

点击某项设置后会在下方

   出现相关说明
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练习 1
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I/O 接口

应用程序

总线接口

I/O 接口

应用程序

总线接口

影响
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练习 2
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小提示

Measurement Setup 窗口和 Simulation Setup 窗口
是 CANoe 的主要窗口，进行数据流规划

几乎窗口中的所有对象均可通过点击鼠标右键来
访问交互菜单

所有数据传输到评估模块时，均会在对应窗口以
各自的方式进行显示，记录模块除外

配置文件可以保存 CANoe中的所有设置；可以使
用已有的配置文件作为新任务的基础，进行简单
的修改形成新的配置，提高效率
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在 CANoe中添加数据库

 View->Simulatioin Setup

蒙太奇（ 1）
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蒙太奇（ 2）

符号化显示与十进制 /十六进制切换
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Global switches:  Hex/Dec and Numeric/Symbolic toggles 
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蒙太奇（ 3）
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暂停显示

显示测试点

测试范围

变灰其余信号

隐藏其余信号

单信号

多信号

坐标模式

缩小

放大
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蒙太奇（ 3）
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所有信号全 XY轴显示

所有信号 Y轴显示

根据指定信号 XY轴显示

根据指定信号 Y轴显示

指定时间范围显示

信号上移

信号下移

设置显示时间范围

信号左移至开始

信号左移

信号右移

信号右移至结束

取消

重做

Y轴显示模式

网格

信号点迹

停止 / 开始
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Graphics 与 Trace 窗口同步

图形窗口

 右键单击空白处

 Extras->Synchronize Windows

定位同一时间不同窗口中数据

蒙太奇（ 4）
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R
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Graphics 、 Trace 、 Data 窗口间鼠标拖放数据

蒙太奇（ 5）
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L
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蒙太奇（ 6）

Desktop
 Create New Desktop

 Rename Desktop
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蒙太奇（ 7）

固定窗口
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蒙太奇（ 8）

离线分析 - 回放记录文件

 Mode->To Offline
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版本记录
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版本 更改描述 更改日期 更改人

1.0 初始版本 2008-06-18 高路

1.1 修改蒙太奇链接 2008-07-06 王晗

1.2 增加模块表格 2008-08-06 王晗
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